Turn signals

Discussion in 'Other Repairs' started by fishermanfred, May 17, 2006.

  1. fishermanfred

    fishermanfred New Member

    Messages:
    12
    I bought a 77 ford 1 ton, the turn signals work, but when I turn the lights on the turn signals do not work. Where do I start to look for the problem?
     
  2. shortshank

    shortshank New Member

    Messages:
    389
    State:
    Oregon
    The ground wire is grounded or the turn indicators wouldn't work at all. But check the ground wire at the tail light housing anyway. I've replaced several ground wires that could not handle brake light+ turn indicator, park lights + turn indicator combinations. Try brake light and turn indicator and see if they fail. Then check turn switch if everything else worked.:misdoubt: :baffle:
    Don
     

  3. fishermanfred

    fishermanfred New Member

    Messages:
    12
    Thanks Don, I will ask my son to help me this week end, that is where we will start. If I have more trouble I will ask again.
     
  4. trnsmsn

    trnsmsn New Member

    Messages:
    1,214
    State:
    Missouri Originally Now I
    I'm With Don On This One, I'll Bet That A Ground Is The Issue, As Don Said It Can Pull Enough Ground For One Curcuit But Not All Of Them.

    Make Sure That You Have A Good Chassis Ground, That Will Be A Wire Going From The Body, Usually The Fender, DIRECTLY Back To The Negative Post On The Battery.

    HTH,Elliot
     
  5. tspergin

    tspergin New Member

    Messages:
    867
    State:
    newark ohio
    If you dont have a heavy duty turn signal flasher it will do the same thing should use a heavy duty one for extra lights anyway, ck it before replacing any parts ,hope this helps