trolling trouble

Discussion in 'Boating' started by flatheadcat4u, Mar 24, 2009.

  1. flatheadcat4u

    flatheadcat4u New Member

    Messages:
    182
    State:
    Westmoreland, K
    how the heck do ya get this troll ing motor off ? i broke the head unit plastic coming in to dock and now i cant get the 4 screws out that hold it to the boat help me please its a max 55 mod minnkota
     
  2. metalman

    metalman Well-Known Member

    Messages:
    3,447
    State:
    IN
    Name:
    Winston
    Nate,
    When you say you can't get the screws out, do you mean they won't turn or that the screw heads are boogered up. Are they hex head bolts, or slotted/Philips screws? Give us a bit more info.
    ...W
     

  3. kyleco55

    kyleco55 Well-Known Member

    Messages:
    1,359
    State:
    Central In
    well im sure there will be ALOT better advice coming along real soon for this.. BUT.. if ALL ELSE fails, get you a BFH.. ( Big Friggin Hammer )


    probably be cheaper in the long run to use someone elses advice first though:smile2::smile2:
     
  4. flatheadcat4u

    flatheadcat4u New Member

    Messages:
    182
    State:
    Westmoreland, K
    phil head screws that just keep turning :embarassed:
     
  5. metalman

    metalman Well-Known Member

    Messages:
    3,447
    State:
    IN
    Name:
    Winston
    Grind 'em off or shear the heads off with a sharp chisel and a not so "big friggin hammer":wink:
    ...W
     
  6. kyleco55

    kyleco55 Well-Known Member

    Messages:
    1,359
    State:
    Central In
    come on metalman.. ya always gotta take the fun outta it:smile2:
     
  7. ncfowler

    ncfowler Well-Known Member

    Messages:
    2,630
    State:
    NC
    Name:
    Jeff
    if it is a bow mount (not knowing your boat) on my boat i have to remove the plug mount on my deck, leaving a opening big enough to put my hand and arm in, then i can reach the nuts on the bottom of the screws holding on my motor. If you have the type of mounts that are molded rubber with inserts, the inserts may be broke loose form the rubber or the rubber inserts them selfs may be spinning, you need to hold them with a pair of channel locks. If you are just repairing you motor you may be able to remove the motor and leave the mount in tack, I can remove my motor and leave the mount, two years ago i did the same thing you did and got new parts form minkota for about 10 bucks, it is a easy fix.
     
  8. flatheadcat4u

    flatheadcat4u New Member

    Messages:
    182
    State:
    Westmoreland, K
    didnt even thank about that they might have nuts on them thanks :roll_eyes: