trailer turn signals

Discussion in 'Boat Tips' started by bigmaac73, Feb 8, 2008.

  1. bigmaac73

    bigmaac73 Member

    Messages:
    434
    State:
    Lenoir City, TN
    Hey all, having an issue, at least I think it is an issue. I have a 92 s-10 and just got a trailer for my jon boat from a friend. I had to replace all the wiring on the trailer. I had to also replace the wiring harness for my tail lights as it kept causing me to blow tail lights. My question is this. When my trailer is not hooked up the blinkers work fine. When I hook up the trailer, by blinkers flash really fast like they do when you have a light out. ALL of the lights work they are just flashing really fast. When I push in my four ways, they flash at normal speed, but for some reason when it is just my turn signals, they flash reallly fast. Any ideas? I thought it was either a bulb or a ground so I redid EVERY ground of the trailer. Still same thing. I used a volt meter on the trailer harness and it seemed normal, but it is not. Anyone know anything?
     
  2. biga

    biga Well-Known Member

    Messages:
    2,112
    State:
    evansville
    you may need a heavy duty flasher...
     

  3. bigmaac73

    bigmaac73 Member

    Messages:
    434
    State:
    Lenoir City, TN
    so you think that the lights on the trailer are not the right ones?
     
  4. AwShucks

    AwShucks New Member

    Messages:
    4,532
    State:
    Guthrie, Oklaho
    My vote is also for a heavy duty flasher.
     
  5. lawnman61

    lawnman61 New Member

    Messages:
    1,694
    State:
    Fort Worth, Tex
    What he said, most of the time that works.
    Replace flasher under the dash with a heavy duty one.

    :wink:
     
  6. bigmaac73

    bigmaac73 Member

    Messages:
    434
    State:
    Lenoir City, TN
    oh, you mean the flasher that plugs in under the dash by the fuse box?
     
  7. lawnman61

    lawnman61 New Member

    Messages:
    1,694
    State:
    Fort Worth, Tex
    Yeppers, that would be the one brother. :wink:
     
  8. bigmaac73

    bigmaac73 Member

    Messages:
    434
    State:
    Lenoir City, TN
    sweet, I'll giver er a try in the mernin
     
  9. lawnman61

    lawnman61 New Member

    Messages:
    1,694
    State:
    Fort Worth, Tex
    Justin, just wonderin how it turned out brother, did the heavy duty flasher work ?
     
  10. bigmaac73

    bigmaac73 Member

    Messages:
    434
    State:
    Lenoir City, TN
    hey thanks for the help guys, the new HD flasher works like a champ. I would have never known. You guys were spot on.