replacing seals in bottom end

Discussion in 'Bubba's Outboards' started by slimdaddy, Feb 9, 2008.

  1. slimdaddy

    slimdaddy Well-Known Member

    Messages:
    2,604
    State:
    Nelsonville, Oh
    Name:
    Keith
    can i do this myself or should i take it to the shop and about how much does it cost to get this done i bought a used one and dont know if it leaks or not looks like some body put used oil in its blacker than coal but turning the drive shaft the gears feel ok and it shifts ok i dont want to put it on and it leak thanks
     
  2. AwShucks

    AwShucks New Member

    Messages:
    4,532
    State:
    Guthrie, Oklaho
    With the price of lower unit oil as cheap as it is, I think I'd just drain it good, check the old oil for metal filings/shavings, replace the washers on the filling screws and put new fluid in the lower unit. Then, after I ran it the first time, I'd drain the oil and replace it again. You'll know if you had a water leak. LOL
     

  3. Bubbakat

    Bubbakat New Member

    Messages:
    4,532
    State:
    McMinnvill
    Do as lawerance suggest and don't worry about that oil its that color from running it to long not from water intrusion.
     
  4. slimdaddy

    slimdaddy Well-Known Member

    Messages:
    2,604
    State:
    Nelsonville, Oh
    Name:
    Keith
    i was on a site looking at water pumps the housing and it different than the one thats on it bottom end was supposed to be off a 75 115 johnson it showed the housing having one water tube and the one on it has 2 so its an older style from what i can gather can i change housings on it if the spline is the same or is the gearing all different on an older motor but the lower end looks the same as the one one my motor which is a74 85 hp i was fixing this up for a spare or did i get ripped off of ebay maybe take mine off to check any help would be apreiated thanks
     
  5. slimdaddy

    slimdaddy Well-Known Member

    Messages:
    2,604
    State:
    Nelsonville, Oh
    Name:
    Keith
    i just looked at my manual and it shows 2 so the part i was looking atmust of been shown wrong or i was looking wrong :eek:oooh: lol been a long day and smelling to many gas vapors