Catfish Angler Forum at USCA banner
1 - 5 of 5 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 ·
and I'm trying to decide whether it has a problem. The bait clicker works just fine, but when I try to disengage it the reel still seems to click and not free spool as freely as it should. It doesn't click as loudly, but it still clicks.

Does this reel have a problem? Shouldn't it be silent when the bait clicker is disengaged?

Overall, the reel seems about like new. It is spooled with some kind of a superbraid line, but it doesn't look like it's been fished with.

Please give me some advice on how to make this thing work as well as it should -- or should I try to return it?

Thanks for your help.
 

·
Registered
Joined
·
9,715 Posts
You could take off the sideplate and adjust the clicker very easy to do.
If not, I'd return and get my $ back. I think you could fix it yourself, just bend the copper/brass back a tad and that should fix it.
Let us know what you do or figure out.
Good Luck!!:big_smile:
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #4 ·
You could take off the sideplate and adjust the clicker very easy to do.
If not, I'd return and get my $ back. I think you could fix it yourself, just bend the copper/brass back a tad and that should fix it.
Let us know what you do or figure out.
Good Luck!!:big_smile:

John, THANK YOU!

This repair was incredibly easy. I just had to undo the two screws that fit into the posts, and this let me take the whole reel apart. I played around with it a little to see how the pieces work together. The screw inside the reel that holds the metal clicker piece in place was a little loose. I pushed the clicker piece slightly to slide it into its proper position and tightened the loose screw. All I had to do next is put it all back together.

Now it works GREAT -- smooth as butter and silent like it should be.

Thanks for the help!

As a newbie to the BOC it's nice to learn that this site is not just interesting and informative. It's reallly useful, too!
 

·
Registered
Joined
·
9,715 Posts
You are very welcome Bro! I'm glad that helped and you're good to go now. I've had that problem before also thats why I suggested that.
I wish you the best of luck with it!!!
Keep us posted on how it works and how you do with it!





John, THANK YOU!

This repair was incredibly easy. I just had to undo the two screws that fit into the posts, and this let me take the whole reel apart. I played around with it a little to see how the pieces work together. The screw inside the reel that holds the metal clicker piece in place was a little loose. I pushed the clicker piece slightly to slide it into its proper position and tightened the loose screw. All I had to do next is put it all back together.

Now it works GREAT -- smooth as butter and silent like it should be.

Thanks for the help!

As a newbie to the BOC it's nice to learn that not only is this site interesting and informative. It's reallly useful, too!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top