Catfish Angler Forum at USCA banner
1 - 20 of 89 Posts

·
Registered
Joined
·
1,424 Posts
Discussion Starter · #1 ·
Well guys in keeping with the spirit of the other threads. Post your March Fishing reports and conquest here. Hopefully this will be the month the weather starts to warm up enough for me to give it a try.:wink:
 

·
Registered
Joined
·
340 Posts
Yeah, I am chompin' at the bit somethin' fierce...was going to head up to Jim Thorpe this weekend, but a little too cold for me just yet (plus there may be ice on the lakes still---not sure).

If I do not get out there soon, I'll go broke from buying so much equipment on the web.:smile2:

Hope to have some real posts for you soon....
 

·
Registered
Joined
·
10,863 Posts
I'll be on the ice again this weekend! :cool2: Hardwater season will be ending soon but I will be out till it does! :wink: One of my goals each year is to land a fish in all 12 months of the year. So far, so good with Jan. & Feb. I plan on getting on the March scoreboard Saturday! :big_smile:
 

·
Registered
Joined
·
568 Posts
I was on the ice 2/28 I managed 3 Trout,1 was a freshley stocked Rainbow about 11" 1- 13" and 1- 16" Rainbow plus 1- 13' Perch The temp was about 12* at the most with wind about 15 to 20 mph. I sometime wonder why I do this. I had to fire op the lantern for the first time this year to stay worm.:angry: 2/29 I fished a local pond, my total for the day was 1 LMB 16", 1 Perch 11", and about 8 Gill's on the smallish side. Agen a cold day, but I dident need the lantern :wink: Now it's snowing agen, the man said about 6 more inches, will this winter ever end.:tounge_out:
 

·
Registered
Joined
·
1,993 Posts
I'll try but the weather this time of year hates me and stalks me on my days off.
 

·
Registered
Joined
·
10,863 Posts
I was out on the ice today at Glade Run Lake. Ice was 7 1/2" thick. I caught 2 Rainbow Trout and 7 bluegill. I lost a couple Trout at the hole and had a nice Largemouth Bass at the hole that spit the hook, I sank my arm up to my elbow trying to grab him and had it by the tail but it squirmed away! I'm guessing it was about 18". :crazy: Two pics attached! Pic #1 is a nice Trout and pic #2 is awesome Flathead bait! :big_smile:
 

Attachments

·
Registered
Joined
·
10,863 Posts
Fished the hardwater again today at Glade Run Lake. Had a pretty good day icing 6 Rainbow Trout and 1 Bluegill. Real nice day to be out weather wise! Temp. was up near 40* when I quit fishin"! I kept 3 Trout for the fryin' pan! 2 pics attached #1 is me drillin' a hole and #2 is dinner! :cool2:
 

Attachments

·
Registered
Joined
·
10,362 Posts
Uncovered the boat. Cleaned it up. Put the essentials back in it. Put the ears on and fired it up. Ran a check of all the electronic items and all was good. 125 feet of new anchor line. A new chain and a brand new 30# river anchor. It won't be breakin free from them tug wakes this year. LOL! Lubed up the seat pedastals. Installed a new fuel line with new bulb and filter. Attached rod holders and even treated it to new dock lines. LOL! Shot of grease in all the fittings and ran the motor through its paces. Tilt trim and forward and reverse. New lower unit oil. Tested bilge. New cooler cause the lid broke off my old one. Did I leave anything out. LOL!



DID SOMEONE SAY LETS HIT THE RIVER!!!!!:smile2:
 

·
Registered
Joined
·
1,424 Posts
Discussion Starter · #18 ·
Uncovered the boat. Cleaned it up. Put the essentials back in it. Put the ears on and fired it up. Ran a check of all the electronic items and all was good. 125 feet of new anchor line. A new chain and a brand new 30# river anchor. It won't be breakin free from them tug wakes this year. LOL! Lubed up the seat pedastals. Installed a new fuel line with new bulb and filter. Attached rod holders and even treated it to new dock lines. LOL! Shot of grease in all the fittings and ran the motor through its paces. Tilt trim and forward and reverse. New lower unit oil. Tested bilge. New cooler cause the lid broke off my old one. Did I leave anything out. LOL!



DID SOMEONE SAY LETS HIT THE RIVER!!!!!:smile2:

Yeah does it still float....Lol.:big_smile: ...... Congrats on your catch Tan sorry about the break off must of been a big one......:confused2:
 

·
Registered
Joined
·
10,863 Posts
Uncovered the boat. Cleaned it up. Put the essentials back in it. Put the ears on and fired it up. Ran a check of all the electronic items and all was good. 125 feet of new anchor line. A new chain and a brand new 30# river anchor. It won't be breakin free from them tug wakes this year. LOL! Lubed up the seat pedastals. Installed a new fuel line with new bulb and filter. Attached rod holders and even treated it to new dock lines. LOL! Shot of grease in all the fittings and ran the motor through its paces. Tilt trim and forward and reverse. New lower unit oil. Tested bilge. New cooler cause the lid broke off my old one. Did I leave anything out. LOL!



DID SOMEONE SAY LETS HIT THE RIVER!!!!!:smile2:
Sign me up! :big_smile: I'm headin' to "Joisy"! :wink: Sounds like your ready to go George! I hope to get the chance to fish with you someday! :cool2:
 
1 - 20 of 89 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top