Clicker on my Penn 320GT2 doesn't....

Discussion in 'Fishing Reel Review' started by SyKo450, Nov 19, 2009.

  1. SyKo450

    SyKo450 New Member

    Messages:
    884
    State:
    Coachella, Cali
    click anymore, seems like it came a bit loose or something, any ideas on how to solve this problem before I open it up?
     
  2. mintaka

    mintaka Well-Known Member

    Messages:
    1,471
    State:
    Charlotte , N.C
    Not without opening. Just be cautious not to lose any small parts. It may be simple as out of place gears or lubrication. Good Luck!!
     

  3. SyKo450

    SyKo450 New Member

    Messages:
    884
    State:
    Coachella, Cali
    I set the clicker on, I reel in and it clicks loud like it should, but when I set the drag to 0 and pull the line, the clicking is very faint

    Reel is only about 25 casts old, I have forgotten to disengage the clicker and casted no more than 5 times, might that have caused something?
     
    Last edited: Nov 19, 2009
  4. MAX1955

    MAX1955 New Member

    Messages:
    1,070
    State:
    KENTUCKY
    :eek:oooh: I'm not sure what you mean when you say you set the drag to zero, normally you put a reel in free spool when setting the clicker. But then I'm not real familar with penn reels, I use abu. I will say I had the same problem with a reel I had just bought, and I sent it back and had them fix it. The only cost to me was mailing it to them (abu). While I could have fixed it myself I figure they should make it right, it was a newer reel I used three or four times when the clicker went bad. There isn't much to a clicker. If it was me I would send it back with a letter and let them fix it, I've heard good things about penn on this site.