Boat in the shop

Discussion in 'Bubba's Outboards' started by crazy, Jun 11, 2008.

  1. crazy

    crazy New Member

    Messages:
    2,090
    State:
    Kansas CIty, MO
    Well I took my boat to the shop yesterday. Turns out the impeller housing and the impeller it's self was melted pretty bad. It must have something to do with over heat light thats been coming on since last year. Way to go Yamaha for building a heck of a 4x4 motor. :big_smile:
     
  2. Bubbakat

    Bubbakat New Member

    Messages:
    4,532
    State:
    McMinnvill
    Are you asking for advice or just making a statement here. Sounds like you whas running it out of the water as in dry starting it to melt the housing and all or running it into mud without cleaning the mud out. Just wondering here don't see as yahama did anything wrong but if it heated last year why wait so long to repair it.
     

  3. crazy

    crazy New Member

    Messages:
    2,090
    State:
    Kansas CIty, MO
    Why did I wait so long? Because it never gave me a reason too take it in. It never failed still did not fail when I took it in. Performed like it should every time. No mud just sand and lots of it. The motor is only a year and half old.
     
  4. Bobpaul

    Bobpaul New Member

    Messages:
    3,039
    State:
    Supply NC
    Bubba, I don't think anymore questions would help:wink:
     
  5. Bubbakat

    Bubbakat New Member

    Messages:
    4,532
    State:
    McMinnvill
    I guess that heat warning light is on there for looks. That is why they call them warning lights and horns and not failure horns and lights.