99 Z71

Discussion in '4X4 Truck Talk and Repairs' started by Steven Armstrong, Mar 24, 2009.

  1. Steven Armstrong

    Steven Armstrong New Member

    Messages:
    405
    State:
    Sallisaw,Oklahoma
    my Z71 is slow starting, when i first got it ,you couldn`t get off the key quick enough, now it acts like its waitng on fuel. any ideas what may be wrong?
     
  2. psychomekanik

    psychomekanik New Member

    Messages:
    2,534
    State:
    Illinois
    It might be waitin on fuel! LOL, check fuel pressure...High mileage??? possibly dirty fuel filter, fuel pump, Dirty M.A.F. sensor, old plugs, or D. all the above..
     

  3. catfishfever1

    catfishfever1 New Member

    Messages:
    67
    State:
    kansas
    i had the same problem with my 99 z71 i replaced evrything fuel filter,plug,wires and then i took it in and had the fuel injectors clened and that fixed the problem.it cost me just a little over a 100 buck at the dealer
     
  4. psychomekanik

    psychomekanik New Member

    Messages:
    2,534
    State:
    Illinois
    Thats a good idea from a maintenance perspective also. Try some in tank cleaner with a half a tank of gas or less. It might help some.
     
  5. Mike81

    Mike81 Well-Known Member

    Messages:
    4,186
    State:
    Alabama
    Another thing to check is the battery and starter. As they get older they still work but don't perform like they used to, ya know like us. :wink:

    Seriously though, make sure both are in top shape before replacing alot of other stuff.