Catfish Angler Forum at USCA banner
1 - 5 of 5 Posts

· Registered
Joined
·
3,318 Posts
Discussion Starter · #1 ·
Well I changed the LU oil today and that dreaded milk like color came out, so I am going to go ahead and reseal the LU. Now we did my Evinrude a year or so ago and once you removed the prop and its components, there were visible bolts inside the housing that you had to remove, in order to pull the bearing carrier and prop shaft out. When I looked inside the housing for my Yamaha today, there were no bolts to remove. Is everything pressure fitted in this motor? Do ya just use a puller and remove the goods? It just seems weird to me I have never removed one that had no bolts?

Thanks all...
 

· Registered
Joined
·
4,613 Posts
Travis there is a speciel tool you have to have to pull the yamaha lower unit apart to replace the seals ,sorry to tell you that ,from what i hear you will damage the housing with out it
 

· Registered
Joined
·
3,318 Posts
Discussion Starter · #3 ·
Travis there is a speciel tool you have to have to pull the yamaha lower unit apart to replace the seals ,sorry to tell you that ,from what i hear you will damage the housing with out it
So you cant use a regular puller??? Man the pullers for yamaha I have priced are close to 300$!!! There has got to be another way....Crap! Now I officially have no clue what to do.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top