1974 Johnson 70 Hp

Discussion in 'Bubba's Outboards' started by Skunk Master, Jun 2, 2007.

  1. Skunk Master

    Skunk Master New Member

    Messages:
    3,366
    State:
    Colinsville, Il
    It was running fine until last weekend, I got caught in a big rainstorm and it would only run half throttle, acted like I was towing a barge.. When I went to load it on trailer it didn't have the power to load itself.. I thought I was out of gas on the tank I was using.. Filled both tanks up today, went back to river.. Hard to start and kept popping like it was running lean until it warmed up.. Still only ran 1/2 throttle and no Power.. Does it have a fuel filter.. I traced fuel line to fuel pump on motor..Couldn't find one.. Bubba or Paul please help.. I don't have a repair manual on it, just a worn out copy of the owners manual.. What year did they switch over from points to electronics.. Thanks in advance.. I have faith in you guy's..
     
  2. Bobpaul

    Bobpaul New Member

    Messages:
    3,039
    State:
    Supply NC
    You don't have points!

    You need to check for spark at each cylinder. Damned things have a way of breakin down. I doubt it was because of the rainstorm.

    If you don't hear a gosh aweful clatter, I doubt you blew the engine either, but a compression check would be a good thing to do.

    Could be anything from fouled carb's, spark plugs,a coil, power pack, or stator.

    Water in your fuel system could cause such a problem. You've got some checking to do.
     

  3. Skunk Master

    Skunk Master New Member

    Messages:
    3,366
    State:
    Colinsville, Il
    Thanks Bobpaul.. I was afraid you were going to say that.. I've been a mechanic most of my life.. Just never learned anything about boat motors.. I guess you're never too old to start huh..
     
  4. Skunk Master

    Skunk Master New Member

    Messages:
    3,366
    State:
    Colinsville, Il
    It runs like a new motor out on the water at 1/4 throttle.. It never did like to idle or go no wake speed.. I bought it last spring off a friend, so it's been taken care of..
     
  5. Bobpaul

    Bobpaul New Member

    Messages:
    3,039
    State:
    Supply NC
    If that older 70 hasn't had the upgrade modification to the water cooling system, keep that water pump, changed at least every other year.

    And that low speed running, could be a carb problem or they're just not set right.