1973 Mercury 850

Discussion in 'Bubba's Outboards' started by jgdishon, Dec 11, 2006.

  1. jgdishon

    jgdishon New Member

    Messages:
    62
    State:
    Snowville,Virgi
    I have a 85hp 1973 Mercury 4 cyl that I am trying to restore. It has great compression (160 in all cyl) and the the lower unit looks to be ok. My problem is the wires are all rotten and the distributor cap is missing. My question? Is there an electronic ignition convertion for a 4 cyl engine? I think that might be easier than replacing these old parts? Thanks
     
  2. Bobpaul

    Bobpaul New Member

    Messages:
    3,039
    State:
    Supply NC
    You've got a common problem. Even the wires from the stator have rotting insulation and green wire. I've never been able to do much about it.
     

  3. jgdishon

    jgdishon New Member

    Messages:
    62
    State:
    Snowville,Virgi
    Im pretty good with the wireing stuff. I have crimpers and a good soldering iron but I have not been able to find the distributor cap and plug wires for less than a arm and a leg.
     
  4. Bubbakat

    Bubbakat New Member

    Messages:
    4,532
    State:
    McMinnvill
    Jeffery, I'll check with some of these old dealers around here and see if they may have one left over from a part out.
     
  5. jgdishon

    jgdishon New Member

    Messages:
    62
    State:
    Snowville,Virgi
    If I dont find one soon this motor is going back on the local swap and shop were I found it. I need to start parking in the garage again. Its getting petty cold over here at night and im tired of scraping the frost every morning.
     
  6. beakus

    beakus New Member

    Messages:
    243
    State:
    derby kansas
  7. jgdishon

    jgdishon New Member

    Messages:
    62
    State:
    Snowville,Virgi
    But im not sure they dont want more for the cap and wires than the motor is worth. They want rite at 200.00